ESLint v6.0.0-alpha.0 released

We just pushed ESLint v6.0.0-alpha.0, which is a major release upgrade of ESLint. This release adds some new features and fixes several bugs found in the previous release. This release also has some breaking changes, so please read the following closely.

Highlights

Most of the highlights of this release are breaking changes, and are discussed further in the migration guide.

Non-breaking highlights:

Installing

Since this is a pre-release version, you will not automatically be upgraded by npm. You must specify the next tag when installing:

npm i eslint@next --save-dev

You can also specify the version directly:

npm i eslint@6.0.0-alpha.0 --save-dev

Migration Guide

As there are a lot of changes, we’ve created a migration guide describing the changes in great detail along with the steps you should take to address them. We expect that most users should be able to upgrade without any build changes, but the migration guide should be a useful resource if you encounter problems.

Breaking Changes

Enhancements

Bug Fixes

Documentation

  • 8bfd1d1 Docs: add v6.0.0 migration guide (#11515) (Teddy Katz)
  • cbdee62 Docs: README updates to reflect JSCS compat project is finished (#11568) (Kevin Partington)
  • 595de40 Docs: edit arrow-parens as-needed explanation (fixes #11202) (#11569) (Logan Lowder)
  • a73b4b8 Docs: Update README team and sponsors (ESLint Jenkins)

Dependency Upgrades

  • eeea893 Upgrade: update js-yaml package to 3.13.1 version (#11607) (Pobegaylo Maksim)
  • e70d5f7 Upgrade: compatible deps (#11608) (薛定谔的猫)
  • 3396c3e Upgrade: karma@^4.0.1, drops Node 6 support, fixes vulnerability (#11570) (Kevin Partington)

Chores

  • 3d9e137 Chore: fix test that fails when the CWD contains a space (#11612) (Teddy Katz)